day4 POJ3984

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
分析:bfs简单的走迷宫,难点在于如何记住路线;记住最后输出的坐标还有空格

#include<iostream>
using namespace std;
#include<queue>
char a[10][10];//输入迷宫
bool book[10][10];//标记
int dx[30]={0,1,-1,0};//方向
int dy[30]={-1,0,0,1};
struct node
{
	int x,y;
	int s;//最短路径
	int l[30];//记住路线
};
node bfs();
int main()
{
	memset(book,0,sizeof(book));
	for(int i=1;i<=5;i++)
		for(int j=1;j<=5;j++)
		{
			cin>>a[i][j];
		}
		book[1][1]=1;
		node ans=bfs();
		int x=0,y=0;
		cout<<"(0, 0)"<<endl;
		for(int i=0;i<ans.s;i++)
		{
			x+=dx[ans.l[i]];
			y+=dy[ans.l[i]];
			cout<<"("<<x<<","<<" "<<y<<")"<<endl;
		}
		
}
node bfs()
{
	node pre,next;
	int nx,ny;
	pre.s=0;//开始状态
	pre.x=1;
	pre.y=1;
	queue<node>q;
	q.push(pre);//入队
	while(!q.empty())
	{
		pre=q.front();
		q.pop();
		if(pre.x==5&&pre.y==5)
		return pre;
	for(int i=0;i<4;i++)
	{
		nx=pre.x+dx[i];
		ny=pre.y+dy[i];
		if(nx>=1&&ny>=1&&nx<=5&&ny<=5&&book[nx][ny]==0&&a[nx][ny]=='0')//基本满足条件
		{
			next=pre;
			next.x=nx;
			next.y=ny;
			next.s=pre.s+1;//增加步数
			next.l[pre.s]=i;//记忆路线
			book[nx][ny]=1;//标记
			q.push(next);
	
		}
	}
	}
	return pre;
}

猜你喜欢

转载自blog.csdn.net/weixin_43792166/article/details/86622000