HDU--1114Piggy-Bank【完全背包】

题目链接

Problem Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input

3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.

The minimum amount of money in the piggy-bank is 100.

解题思路:这题属于完全背包。完全背包和01背包的区别在于每种物品的数量,完全背包是无限制的,而01背包是每种物品只有一个,在代码中的区别是01背包内循环是逆序的,而完全背包内循环是顺序的,我们这题很明显,没有限制物品的数量,我们只要找最小值,我们先将答案ans的每一个都赋值为最大值INF,我在这里犯了一个错误,就是INT_MAX常量加正数都会溢出,所以导致第三个例子溢出。

#include<bits/stdc++.h>
using namespace std;
int w[510],v[510];
int ans[10000];
const int INT=0x3f3f3f3f;
int main(void)
{
    int ncases,n,vempty,vfill,maxw;
    scanf("%d",&ncases);
    while(ncases--)
    {
        scanf("%d%d",&vempty,&vfill);
        maxw=vfill-vempty;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        scanf("%d%d",&v[i],&w[i]);
        memset(ans,0x3f,sizeof ans);
        ans[0]=0;
        //完全背包
        for(int i=1;i<=n;i++)
        {
            for(int j=w[i];j<=maxw;j++)
            {
                ans[j]=min(ans[j],ans[j-w[i]]+v[i]);
            }
        }
        if(ans[maxw]==INT)
            printf("This is impossible.\n");
        else
             printf("The minimum amount of money in the piggy-bank is %d.\n",ans[maxw]);
    }
    return 0;
}

This is impossible.

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82683453