【HDU 1114】Piggy-Bank(DP-完全背包)

Piggy-Bank


Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!


Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.
Output
Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.


Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.


题意:

输入T组数据,E表示空存钱罐质量,F表示存钱罐装满时的质量。(F-E即为容量)接下来输入N表示硬币种类数量。之后N行每行分别输入硬币重量W和价值P(面值)。要求存钱罐中最少有的钱数。
我们首先来了解一下完全背包问题。

完全背包问题:

非常类似于01背包问题。有N种物品和一个容量为V的背包,每种物品数量无限。第i种物品的费用是c[i],价值是w[i]。求解将哪些物品装入背包可使这些物品的价值总和最大。其代码和01背包(01背包例题及讨论)只有一处不同:
for i=1..N
    for v=0..V
        dp[v]=max{dp[v],dp[v-cost]+weight}
对比发现,只有第二层for循环的顺序不同(恰好相反)。

思路:

那么根据完全背包问题的套路,此题要求最小价值,只需要把max改为min即可。

代码示例:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm> 
#define MAX  10005
#define INF 0x3f3f3f3f

using namespace std;
int dp[MAX];
int main()
{
    int t;
    cin>>t;
    int emp,fill;
    int n;
    int weight[MAX],pay[MAX];
    while(t--)
    {
        cin>>emp>>fill;
        int val=fill-emp;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>weight[i]>>pay[i];
        }
        for(int i=0;i<=val;i++) dp[i]=INF;
        dp[0]=0;
        for(int i=0;i<n;i++)
            for(int j=pay[i];j<=val;j++)
                if(dp[j-pay[i]]<INF )
                    dp[j]=min(dp[j],dp[j-pay[i]]+weight[i]);
        if(dp[val]>=INF) cout<<"This is impossible."<<endl;
        else cout<<"The minimum amount of money in the piggy-bank is "<<dp[val]<<"."<<endl;
    }


    return 0;
 } 

猜你喜欢

转载自blog.csdn.net/chen_yuazzy/article/details/77008420
今日推荐