G - Balanced Lineup ( 线段树+区间查询无更新)

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2.. NQ+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

题意:在一夕间内,最大值和最小值之差

#include<stdio.h>
#include<iostream>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int N=1e6+10;
int ma[N*4];
int mi[N*4];
const int inf=0x3f3f3f;
void build(int l,int r,int rt)
{
    if(l==r)
    {
        scanf("%d",&ma[rt]);
        mi[rt]=ma[rt];
        return ;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    ma[rt]=max(ma[rt<<1],ma[rt<<1|1]);
    mi[rt]=min(mi[rt<<1],mi[rt<<1|1]);
}
int queryma(int L,int R,int l,int r,int rt)
{
    if(L<=l&&R>=r)
        return ma[rt];
    int m=(l+r)>>1;
    int ret=0;
    if(L<=m)
        ret=max(ret,queryma(L,R,lson));
    if(R>m)
        ret=max(ret,queryma(L,R,rson));
    return ret;
}
int querymi(int L,int R,int l,int r,int rt)
{
    if(L<=l&&R>=r)
        return mi[rt];
    int m=(l+r)>>1;
    int ret=inf;
    if(L<=m)
        ret=min(ret,querymi(L,R,lson));
    if(R>m)
        ret=min(ret,querymi(L,R,rson));
    return ret;
}
int main()
{
    int n,m,s,e;
    scanf("%d%d",&n,&m);
    build(1,n,1);
    for(int i=1; i<=m; i++)
    {
        scanf("%d%d",&s,&e);
        printf("%d\n",queryma(s,e,1,n,1)-querymi(s,e,1,n,1));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chen_zan_yu_/article/details/83540010