POJ - 3264 Balanced Lineup 线段树 ST表模板

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2.. NQ+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
#include<vector>
#include<set>
#include<queue>
#include<algorithm>
#include<stack>
#include<cstdlib>
#include<cctype>
using namespace std;
#define ll long long
typedef pair<int,int>P;
const int len=1e6+5;
int arr[len];
int a[len][25];//存最大值 
int b[len][25];//存最小值 
int main()
{
    int n,q;
    cin>>n>>q;
    for(int i=1;i<=n;++i)scanf("%d",arr+i);
    for(int i=1;i<=n;++i)a[i][0]=b[i][0]=arr[i];//长度为2的0次方为自己 
    for(int j=1;(1<<j)<=n;++j)
    {
    	for(int i=1;i+(1<<j)-1<=n;++i)
    	{//a[i][j]的意思是从i这个位置开始共有2的j次方个数的值打值
		//区间dp的思想二个小的区间合成一个打区间 
		//max(a[5][3]=max(a[5][2],a[9][2]  i,j 
		//a(5,12)=max(a(5,8),a(9,12))  区间 
    		a[i][j]=max(a[i][j-1],a[i+(1<<(j-1))][j-1]);
    		b[i][j]=min(b[i][j-1],b[i+(1<<(j-1))][j-1]);
		}
	}
	while(q--)
	{
		int l,r;
		scanf("%d%d",&l,&r);
		int k=log(r-l+1)/log(2);//k为比区间长度小的最大的2的次方的值 
		int maxm=max(a[l][k],a[r-(1<<k)+1][k]);//区间覆盖了也没有关系 
		int minm=min(b[l][k],b[r-(1<<k)+1][k]);
		printf("%d\n",maxm-minm);
	} 
}

猜你喜欢

转载自blog.csdn.net/hutwuguangrong/article/details/81139772