图论基础算法之最小生成树kruskal算法之Highways

Highways
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 36259 Accepted: 16227
Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They’re planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.
Input

The first line of input is an integer T, which tells how many test cases followed.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.
Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.
Sample Input

1

3
0 990 692
990 0 179
692 179 0
Sample Output

692

代码

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
struct node
{
    int l,r,v;
    friend bool operator <(node a,node b)
    {
        return a.v<b.v;
    }
}p[65536];
int f[503];
void init()
{
    for(int i=0;i<503;i++)
        f[i]=i;
}
int max(int x,int y)
{
    return x>y?x:y;
}
int find(int x)
{
    if(x==f[x]) return x;
    return f[x]=find(f[x]);
}
void join(int x,int y)
{
    if(x!=y) f[find(x)]=find(y);
}
int main()
{
    int t;
    cin>>t;

    while(t--)
    {
        int n;
        int k=0;
        init();
        cin>>n;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                scanf("%d",&p[k].v);
                p[k].l=i;
                p[k].r=j;
                k++;

            }
        }
        sort(p,p+k);
        int ans=0;
        for(int i=0;i<k;i++)
        {
            if(find(p[i].l)!=find(p[i].r))
               {
                   join(p[i].l,p[i].r);

                ans=max(ans,p[i].v);
               }

        }
        cout<<ans<<endl;

    }



    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42825221/article/details/81605241
今日推荐