PAT甲级 1003 Dijkstra求最短路径

题目

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) – the number of cities (and the cities are numbered from 0 to N-1), M – the number of roads, C1 and C2 – the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output
2 4


题解

每次都从未攻战的城市中选择离起点V0最近的城市Vk,再找到离VK最近的,比较d[vk]+G[v(k+1)]与d[v(k+1)]哪个大

求最短路径条数 和 途中的点权最大和。

#include<iostream>
#include<algorithm>
using namespace std;
const int MAXN=501;
  const int INF=99999999;
  int G[MAXN][MAXN];
  int d[MAXN];
  bool vis[MAXN];
  int weight[MAXN];
  int w[MAXN];
  int num[MAXN];
  int n,m,u,v;
int main(){
  scanf("%d%d%d%d",&n,&m,&u,&v);
  for(int i=0;i<n;i++){
    scanf("%d",&weight[i]);
  }
  fill(G[0],G[0]+501*501,INF);//漏了这句会导致部分正确
  fill(d,d+MAXN,INF);
  int a,c,b;
  for(int i=0;i<m;i++){
      scanf("%d %d %d",&a,&b,&c);
      G[a][b]=G[b][a]=c;
  }
  
  d[u]=0;
  num[u]=1;
  w[u]=weight[u];

  for(int i=0;i<n;i++){
    int u=-1,MIN=INF;
    for(int j=0;j<n;j++){
      if(vis[j]==false&&d[j]<MIN){
        u=j;
        MIN=d[j];
      }
    }

    if(u==-1) break;
    vis[u]=true;
    for(int v=0;v<n;v++){
      if(vis[v]==false&&G[u][v]!=INF){
        if(d[u]+G[u][v]<d[v]){
        d[v]=d[u]+G[u][v];
        num[v]=num[u];//没有重复路径,直接过继最短路径数量
        w[v]=w[u]+weight[v];
     }else if(d[u]+G[u][v]==d[v]){
       num[v]+=num[u];
       if(w[v]<w[u]+G[u][v])
         w[v]=w[u]+weight[v];
     }
    }
  }
 }
printf("%d %d",num[v],w[v]);
return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_24572475/article/details/82735361