1003. Emergency (25)-PAT甲级真题(Dijkstra算法)

1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

迪杰斯特拉(dijkstra)算法是典型的用来解决最短路径的算法

用来求得从起始点到其他所有点最短路径。

采用了贪心的思想每次都查找与该点距离最近的点,也因为这样,它不能用来解决存在负权边的图。

我认为 Dijkstra算法 的本质是 广度优先搜索and贪心的思想

下面给出算法的大致流程:

1.初始化所有结点并将起始点设为标记,进入以下循环

2.在到达某点的最短路径中找最小且未标记的点(可以用一维数组表示)

3.标记找到的点,以此标记点为中间点重新计算所有未标记点的最短路径(更新最短路径表)

4.循环1.2步至n-1次(n为顶点数,若最后还有未被标记的,说明无法到达此点)

题目大意:n个城市m条路,每个城市有救援小组,所有的边的边权已知。给定起点和终点,求从起点到终点的最短路径条数以及最短路径上的救援小组数目之和。如果有多条就输出点权(城市救援小组数目)最大的那个~

分析:用一遍dijkstra算法。救援小组个数相当于点权,用Dijkstra求边权最小的最短路径的条数,以及这些最短路径中点权最大的值~dis[i]:从出发点到i结点最短路径的路径长度,num[i]:从出发点到i结点最短路径的条数,w[i]:从出发点到i点救援队的数目之和。当判定dis[u] + e[u][v] < dis[v]的时候,不仅仅要更新dis[v],还要更新num[v] = num[u], w[v] = weight[v] + w[u]; 如果dis[u] + e[u][v] == dis[v],还要更新num[v] += num[u],而且判断一下是否权重w[v]更小,如果更小了就更新w[v] = weight[v] + w[u];

#include<iostream>
#include<bits/stdc++.h> 
#include<algorithm>
#define  inf 0x3f3f3f3f
using namespace std;
int n,m,c1,c2;//点,边,起始,终点
int e[510][510];//建边
int dis[510];//最短路径
int num[510];//同为最短路径数量
int w[510];//求最大救援数 
int weight[510];//结点救援队数量
bool visit[510];//跑过的点就标记 
int main()
{
	scanf("%d%d%d%d", &n, &m, &c1, &c2);
	
	for(int i = 0; i < n; i++)//点的权重 
      scanf("%d", &weight[i]);
	memset(e,0x3f,sizeof(e));
	memset(dis,0x3f,sizeof(dis));
	
	int a, b, c;//建边 赋值边权 
	for(int i = 0; i < m; i++) 
	{
        scanf("%d%d%d", &a, &b, &c);
        e[a][b] = e[b][a] = c;
    } 
	
	//赋初值 
	dis[c1] = 0;
    w[c1] = weight[c1];
    num[c1] = 1;
	
	for(int i=0;i<n;i++)
	{
	   int u=-1;int minn=inf;
	   for(int j=0;j<n;j++)
	   {//始终挑距源点距离最近的点,对整个图做弱化处理 
	   	   if(visit[j]==false&&dis[j]<minn)
			  {
			  	u=j;
			  	minn=dis[j];
			  } 
	   }	
		
	   if(u==-1)break;//遍历完所有的点,或因为不是连通图,遍历完所有能遍历的点就退出 
	   visit[u]=true;
	  
	  for(int v=0;v<n;v++)
	  {
	  	  if(visit[v]==false&&e[u][v]!=inf)
	  	  {// 标记已走过的点
			if(dis[u]+e[u][v]<dis[v])
			{//弱化处理ing 
				dis[v]=dis[u]+e[u][v];
				
				
				num[v]=num[u];//动规ing 
			    w[v]=w[u]+weight[v];		
			} 
	  	  	else if(dis[u]+e[u][v]==dis[v])
	  	  	{
				num[v]=num[v]+num[u];
				
				if(w[u]+weight[v]>w[v])//动规ing 
				    w[v] = w[u] + weight[v];		
		    } 	  	
		  }
	  } 	
		
	
		
	}
		
 printf("%d %d", num[c2], w[c2]);
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/mlm5678/article/details/82902734
今日推荐