PAT甲级 1003 Emergency

参考链接:点击打开链接

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.\ All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output

2 4

实现代码如下:

#include <iostream>
#include <algorithm>
using namespace std;

#define N 520
int edge[N][N],weight[N],disp[N],w[N],num[N];

bool visited[N] = {false};
const int inf = 999999;

int main(){
	
	fill(edge[0],edge[0] + N * N,inf);//注意这里要是N*N,要不然不是全部 
	fill(disp,disp + N,inf);
	
	int n,m,c1,c2;
	cin>>n>>m>>c1>>c2;
	
	for(int i=0;i < n;i++)
		cin>>weight[i];
	
	int a,b,c;
	for(int i=0;i < m;i++)
	{
		cin>>a>>b>>c;
		edge[a][b] = edge[b][a] = c; 	
	}
	
	disp[c1] = 0;
	num[c1] = 1;
	w[c1] = weight[c1];
	
	for(int i = 0;i < n;i++){
		
		int u = -1,min = inf;
		for(int j = 0;j < n;j++){
			if(visited[j] == false && disp[j] < min){//从未被标记为true的结点(即使算出了disp,但没变为true)中选一个最小的 
				u = j;
				min = disp[j];
			}		
		}
		
		if(u == -1)
			break;
		visited[u] = true;

		for(int v = 0;v < n;v++){
			
			if(visited[v] == false && edge[u][v] != inf){//计算与u有连接的点 
				if(disp[u] + edge[u][v] < disp[v]){
					disp[v] = disp[u] + edge[u][v];
					w[v] = w[u] + weight[v];
					num[v] = num[u];
				}	
				else if(disp[u] + edge[u][v] == disp[v]){
					num[v] = num[u] + num[v];
					if(w[v] < weight[v] + w[u])//有多条就输出点权(城市救援小组数目)最大的那个
						w[v] = weight[v] + w[u];

				}	
				
			}	
		}
	}
	cout<<num[c2]<<" "<<w[c2]<<endl;
	
	return 0;
}

运行结果如下:


猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/80904492