PAT 甲级 1003 Emergency(Dijkstra的运用)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​ , c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​ .

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​ , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

解题思路:本题是对Dijkstra算法的运用,求出最短路径的数量要求,并输出最短路径中最大的结点权值和。在基本算法模板中加上num数组用于存储从起点开始到每一点的最短路径的数量,w[]数组用于存储,从起点到每一点在路径最短的情况下最大权值之和。

代码:

#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
int const MAXV = 1000;
int const INF = 1000000000; 
int weight[MAXV],Adj[MAXV][MAXV];
int d[MAXV];
int vis[MAXV] = {0};
int w[MAXV] = {0};
int num[MAXV] = {0};
int start,end,N,M;
void Dijkstra(int start){
	fill(d,d+MAXV,INF);
	w[start] = weight[start];
	num[start] = 1;
	d[start] = 0;
	for(int i = 0;i < N;i++){
		int u = -1,MIN = INF;
		for(int j = 0;j < N;j++){
			if(vis[j] == 0&&d[j] < MIN){
				MIN = d[j];
				u = j;
			}
		}
		if(u == -1)	return;
		vis[u] = 1;
		for(int j = 0;j < N;j++){
			if(vis[j] == 0&&Adj[u][j]!=INF){
				if(Adj[u][j]+d[u] < d[j]){
					d[j] = Adj[u][j]+d[u];
					w[j]=weight[j]+w[u];
					num[j] = num[u];
				}else if(Adj[u][j]+d[u] == d[j]){
					if(w[j]<w[u]+weight[j]){
						w[j] = w[u]+weight[j];
					}
					num[j]+=num[u];
				}
			}
		}
	}
}
int main(void){
	scanf("%d %d %d %d",&N,&M,&start,&end);
	fill(Adj[0],Adj[0]+MAXV*MAXV,INF);
	for(int i = 0;i < N;i++)
		scanf("%d",&weight[i]);
	for(int i = 0;i < M;i++){
		int m,n,v;
		scanf("%d %d %d",&m,&n,&v);
		Adj[m][n] = v;
		Adj[n][m] = v;
	}
	Dijkstra(start);
	printf("%d %d",num[end],w[end]);
	return 0;
}
发布了69 篇原创文章 · 获赞 5 · 访问量 2042

猜你喜欢

转载自blog.csdn.net/lovingcgq/article/details/104619544
今日推荐