HDU —— 2124 Repair the Wall(贪心)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2124

题目:

问题 : Repair the Wall


题目描述

Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.
When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty's walls were made of wood.
One day, Kitty found that there was a crack in the wall. The shape of the crack is a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors.
The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired perfectly, without any gap.
Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?


输入

The problem contains many test cases, please process to the end of file( EOF ).

Each test case contains two lines.
In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which
mentioned above.
In the second line, there are N positive integers. The ith integer Ai(0<Ai<1000000000 ) means that the ith block has the size of 1×Ai (in inch).

输出

For each test case , print an integer which represents the minimal number of blocks are needed.
If Kitty could not repair the wall, just print "impossible" instead.

样例输入

2 2
12 11 
14 3
27 11 4 
109 5
38 15 6 21 32 
5 3
1 1 1

样例输出

1
1
5
impossible


题目描述:

    有一个宽为1,长度为L的矩形,有n块矩形木板(宽为1)长为A[i]。木板可以切割,求最少需要多少块木板。

排序后,贪心即可。

代码:

#include <stdio.h>
#include<algorithm>
using namespace std;
int main()
{   
    long long i,j,k;
    long long m,n;
    long long a[1010];
    while(scanf("%lld%lld",&m,&n)!=EOF){
        for(i = 0;i<n;i++)   scanf("%lld",&a[i]);
        sort(a,a+n);
        long long sum1 = 0;
        for(i = n-1;i>=0;i--){
            sum1+=a[i];
            if(sum1>=m)  break;
        }
        if(i>=0)
            printf("%d",n-i);
        else
            printf("impossible");
        printf("\n");
    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/hunt_er/article/details/80244392