1110 Complete Binary Tree(25 分)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

思路:

给出一个n表示有n个结点,这n个结点为0~n-1,给出这n个结点的左右孩子,求问这棵树是不是完全二叉树

C++:

#include "cstdio"
#include "iostream"
#include "queue"
#include "string"
using namespace std;
struct node
{
	int lchild,rchild;
};
node tree[25];
int book[25]={0};
int main(){
	int n;
	string temp1,temp2;
	scanf("%d",&n);
	for (int i=0;i<n;i++)
	{
		cin>>temp1>>temp2;
		getchar();
		if (temp1=="-")
		{
			tree[i].lchild=-1;
		}else
		{
			tree[i].lchild=stoi(temp1);
			book[stoi(temp1)]=1;
		}
		if (temp2=="-")
		{
			tree[i].rchild=-1;
		}else
		{
			tree[i].rchild=stoi(temp2);
			book[stoi(temp2)]=1;
		}
	}
	//记录根结点
	int root=-1;
	for (int i=0;i<n;i++)
	{
		if(book[i]==0){root=i;break;}
	}
	queue<int> q;
	q.push(root);
	int cnt = 0, lastnode = 0;
	while(!q.empty()) {
		int temp = q.front();
		q.pop();
		if(temp != -1) {
			lastnode = temp;
			cnt++;
		}else {
			if(cnt != n)
				printf("NO %d", root);
			else
				printf("YES %d", lastnode);
			return 0;
		}
		q.push(tree[temp].lchild);
		q.push(tree[temp].rchild);
	}
	return 0;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ysq96/article/details/81393119