【PAT甲级】1110 Complete Binary Tree(25 分)(完全二叉树)

版权声明:本文为博主原创文章,转载请注明出处。 https://blog.csdn.net/feng_zhiyu/article/details/82432456

题目链接

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

题意:给定二叉树的n个节点(0~n-1)的左右子节点,判断是否为完全二叉树,若是则输出YES和最后一个节点的下标;不是则输出NO和根节点的下标。

思路:若是完全二叉树,那么最大节点的下标应该等于n;否则最大节点的下标应该大于n

代码:

#include <bits/stdc++.h>
using namespace std;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define drep(i,n,a) for(int i=n;i>=a;i--)
#define mem(a,n) memset(a,n,sizeof(a))
#define lowbit(i) ((i)&(-i))
typedef long long ll;
typedef unsigned long long ull;
const ll INF=0x3f3f3f3f;
const double eps = 1e-6;
const int N = 1e5+5;

struct Node {
    int left,right;
} tree[N];
int ans_root,maxn=-1;
bool vis[N];
void dfs(int root,int id) {
    if(id>maxn) {
        maxn=id;///下标
        ans_root=root;
    }
    if(tree[root].left!=-1) dfs(tree[root].left,id*2);
    if(tree[root].right!=-1) dfs(tree[root].right,id*2+1);
}
int main() {
    int n;
    scanf("%d",&n);
    for(int i=0; i<n; i++) {
        string  left,right;
        cin>>left>>right;
        if(left=="-") {
            tree[i].left=-1;
        } else {
            int tmp=stoi(left);
            vis[tmp]=1;
            tree[i].left=tmp;
        }
        if(right=="-") {
            tree[i].right=-1;
        } else {
            int tmp=stoi(right);
            vis[tmp]=1;
            tree[i].right=tmp;
        }
    }
    int root;
    for(root=0; vis[root]!=0; root++);
    dfs(root,1);
    if(maxn==n) {
        printf("YES %d",ans_root);
    } else {
        printf("NO %d",root);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/feng_zhiyu/article/details/82432456