1064 Complete Binary Search Tree(30 分)

1064 Complete Binary Search Tree(30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

思路:题意就是,给你n个数,这些数就无序的不连续的,然后用这些数组成一个完全二叉搜索树。

方法 从小到大排序,然后中序遍历方法插入。 用数组组建二叉树,从头开始遍历 就是层序遍历。

code

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int tree[10000000];
void findnode(int pos,int n);
vector<int> tnode;
int idex = 0;
int main(){
	int n, x;
	cin >> n;
	for (int i = 0; i < n; ++i) {
		cin >> x;
		tnode.push_back(x);
	}
	sort(tnode.begin(), tnode.end());
	findnode(1, n);
	for (int i = 1; i <= n; ++i) {
		if (i != 1) cout << ' ';
		cout << tree[i];
	}
	system("pause");
	return 0;
}
void findnode(int pos,int n) {
	if (pos > n) return;
	findnode(pos * 2, n);
	tree[pos] = tnode[idex++];
	findnode(pos * 2 + 1, n);
}

猜你喜欢

转载自blog.csdn.net/Cute_jinx/article/details/82153477