Characters with Hash

版权声明:转载请注明出处。 https://blog.csdn.net/qq_37708702/article/details/82594516

题目链接
Mur loves hash algorithm, and he sometimes encrypt another one’s name, and call him with that encrypted value. For instance, he calls Kimura KMR, and calls Suzuki YJSNPI. One day he read a book about SHA-256 , which can transit a string into just 256 bits. Mur thought that is really cool, and he came up with a new algorithm to do the similar work. The algorithm works this way: first we choose a single letter L as the seed, and for the input(you can regard the input as a string s, s[i] represents the ith character in the string) we calculates the value(|(int) L - s[i]|), and write down the number(keeping leading zero. The length of each answer equals to 2 because the string only contains letters and numbers). Numbers writes from left to right, finally transfer all digits into a single integer(without leading zero(s)). For instance, if we choose 'z' as the seed, the string “oMl” becomes “11 45 14“.

It’s easy to find out that the algorithm cannot transfer any input string into the same length. Though in despair, Mur still wants to know the length of the answer the algorithm produces. Due to the silliness of Mur, he can even not figure out this, so you are assigned with the work to calculate the answer.

Input

First line a integer T , the number of test cases (T≤10).

For each test case:

First line contains a integer N and a character z(N≤1000000).

Second line contains a string with length N . Problem makes sure that all characters referred in the problem are only letters.

Output

A single number which gives the answer.

样例输入

2
3 z
oMl
6 Y
YJSNPI

样例输出

6
10

题目来源

ACM-ICPC 2018 徐州赛区网络预赛

#include<iostream>
#include<cstring>
#include<vector>
#include<cstdio>
#include<cmath>
using namespace std;
int main(){
    int i,T,N,num;
    vector <int> vec;
    char z,str[1000005];
    scanf("%d",&T);
    while(T--){
        vec.clear();
        memset(str,0,sizeof(str));
        scanf("%d %c%s",&N,&z,str);
        for(i = 0;i < strlen(str);i++){
            num = abs(z - str[i]);
            if(num >= 10){
                vec.push_back(num / 10);
                vec.push_back(num % 10);
            }
            else{
                vec.push_back(0);
                vec.push_back(num);
            }
        }
        for(i = 0;i < vec.size();i++){
            if(vec[i] != 0)
                break;
        }
        if(i == vec.size())//注意点:如果全部为0,那么长度为1!!
            printf("1\n");
        else
            printf("%d\n",vec.size() - i);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37708702/article/details/82594516