ACM-ICPC 2018 徐州赛区网络预赛-I Characters with Hash

Mur loves hash algorithm, and he sometimes encrypt another one's name, and call him with that encrypted value. For instance, he calls Kimura KMR, and calls Suzuki YJSNPI. One day he read a book about SHA-256256 , which can transit a string into just 256256 bits. Mur thought that is really cool, and he came up with a new algorithm to do the similar work. The algorithm works this way: first we choose a single letter L as the seed, and for the input(you can regard the input as a string ss, s[i]s[i] represents the iith character in the string) we calculates the value(|(int) L - s[i]|∣(int)L−s[i]∣), and write down the number(keeping leading zero. The length of each answer equals to 22because the string only contains letters and numbers). Numbers writes from left to right, finally transfer all digits into a single integer(without leading zero(ss)). For instance, if we choose 'z' as the seed, the string "oMl" becomes "1111 4545 1414".

It's easy to find out that the algorithm cannot transfer any input string into the same length. Though in despair, Mur still wants to know the length of the answer the algorithm produces. Due to the silliness of Mur, he can even not figure out this, so you are assigned with the work to calculate the answer.

Input

First line a integer TT , the number of test cases (T \le 10)(T≤10).

For each test case:

First line contains a integer NN and a character zz, (N \le 1000000)(N≤1000000).

Second line contains a string with length NN . Problem makes sure that all characters referred in the problem are only letters.

Output

A single number which gives the answer.

样例输入复制

2
3 z
oMl
6 Y
YJSNPI

样例输出复制

6
10

题意:

根据题目中给出的value的计算公式,可以把每个输入的字符转换成一个两位数的数字 ,然后这些得出的数字从左到右连起来,去掉前导0,数一下剩下的数字有几位就好了。

比如 字符串长度定义为 3 ,seed定义为 a, 那么如果输入aab,转换成数字(000001),去掉前导0,位数就是1,如果输入aba,(000100),位数是3,

重点来了,输入aaa的时候,(000000),输出的位数是1!!!!!多谢我的队友指出这一点!!我是真没想到!

#include <cstdio>
#include <cmath>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn=1e6+5;
char s[maxn];
int q[maxn];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(s,0,sizeof(s));
        memset(q,0,sizeof(q));
        int n;
        char seed;
        scanf("%d %c",&n,&seed);
        getchar();
        scanf("%s",s);
        getchar();
        int tmp = 0;
        for(int j = 0 ; j < strlen(s);j++)
            q[tmp ++] = abs((int)seed - (int)s[j]);
        int c = -1;
        for(int j = 0 ; j < tmp;j++)
        {
            if(q[j] != 0)
            {
                c = j;//第一个不等于0的下标
                break;
            }
        }
        int cnt = 0;//记录结果的位数
        if(c == -1)//value全是零
            cnt = 1;//!!!!!!!!!!!!就是这里!!不是0!!!!!
        else
        {
            if(q[c] > 9)
                cnt = (tmp - c) * 2;
            else
                cnt = (tmp - c - 1) * 2 + 1;
        }
        printf("%d\n",cnt);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hzyhfxt/article/details/82585287