2018ICPC徐州赛区网络预赛I: Characters with Hash

题目来源:

ACM-ICPC 2018 徐州赛区网络预赛I题(计蒜客)
Mur loves hash algorithm, and he sometimes encrypt another one’s name, and call him with that encrypted value. For instance, he calls Kimura KMR, and calls Suzuki YJSNPI. One day he read a book about SHA-256 , which can transit a string into just 256 bits. Mur thought that is really cool, and he came up with a new algorithm to do the similar work. The algorithm works this way: first we choose a single letter L as the seed, and for the input(you can regard the input as a string s , s [ i ] represents the i th character in the string) we calculates the value( ( i n t ) L s [ i ] ), and write down the number(keeping leading zero. The length of each answer equals to 22 because the string only contains letters and numbers). Numbers writes from left to right, finally transfer all digits into a single integer(without leading zero(ss)). For instance, if we choose ‘z’ as the seed, the string “oMl” becomes “11 45 14”.

It’s easy to find out that the algorithm cannot transfer any input string into the same length. Though in despair, Mur still wants to know the length of the answer the algorithm produces. Due to the silliness of Mur, he can even not figure out this, so you are assigned with the work to calculate the answer.

Input
First line a integer T , the number of test cases ( T 10 ) .

For each test case:

First line contains a integer N and a character z , ( N 1000000 ) .

Second line contains a string with length N . Problem makes sure that all characters referred in the problem are only letters.

Output
A single number which gives the answer.

样例输入

2
3 z
oMl
6 Y
YJSNPI

样例输出

6
10

题意:

将给出的字符串中的自负与指定字符进行ascii码相减,取绝对值,并且得出的结果一律留两位数,结果为0就保留00,个位的就在前面加一个0,然后按顺序组成一个新的数,将前导0全部去除,求剩下的数字的位数。

解题思路:

按照题意解决即可,一道简单的水题,其中有一个坑,就是当结果全是0的时候,输出应该为1。

#include<iostream>
#include<cstdio>
#include<cstring> 
#include<algorithm>
#include<cmath>
#include<vector>
#include<deque>
#include<queue>
#include<ctime>
#define INF 0x3f3f3f3f
#define maxn  1005
using namespace std;
typedef long long LL;

char s[1000005];

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        LL m, sum = 0;
        char c;
        scanf("%d %c",&m,&c);
        cin>>s;
        bool flag = true;
        int dis;
        for(int i=0; i<m; i++){
            dis = abs(c-s[i]);
            if(flag){//找到第一个不为0的结果
                if(dis!=0) flag = false;
                if(dis>0 && dis<10) sum =+ 1;、//结果为个位数
                else if(dis>=10) sum+=2;//结果为十位数时
            }
            else sum+=2;//除去第一个,后面的全是两位数
        }
        if(sum == 0) sum =1;//当结果为0的时候(坑所在)
        printf("%d\n",sum);
    }
} 

猜你喜欢

转载自blog.csdn.net/qinying001/article/details/82586854