ACM-ICPC 2018 徐州赛区网络预赛 I 题 Characters with Hash

版权声明:本文为博主原创文章,转载请附上注明就行_(:з」∠)_。 https://blog.csdn.net/vocaloid01/article/details/82595209

Mur loves hash algorithm, and he sometimes encrypt another one's name, and call him with that encrypted value. For instance, he calls Kimura KMR, and calls Suzuki YJSNPI. One day he read a book about SHA-256 , which can transit a string into just 256 bits. Mur thought that is really cool, and he came up with a new algorithm to do the similar work. The algorithm works this way: first we choose a single letter L as the seed, and for the input(you can regard the input as a string s, s[i] represents the i th character in the string) we calculates the value(∣(int)L−s[i]∣), and write down the number(keeping leading zero. The length of each answer equals to 2 because the string only contains letters and numbers). Numbers writes from left to right, finally transfer all digits into a single integer(without leading zero(s)). For instance, if we choose 'z' as the seed, the string "oMl" becomes "11 45 14".

It's easy to find out that the algorithm cannot transfer any input string into the same length. Though in despair, Mur still wants to know the length of the answer the algorithm produces. Due to the silliness of Mur, he can even not figure out this, so you are assigned with the work to calculate the answer.

Input

First line a integer T , the number of test cases (T≤10).

For each test case:

First line contains a integer N and a character z, (N≤1000000).

Second line contains a string with length N . Problem makes sure that all characters referred in the problem are only letters.

Output

A single number which gives the answer.

样例输入

2
3 z
oMl
6 Y
YJSNPI

样例输出

6
10

题目来源

ACM-ICPC 2018 徐州赛区网络预赛 

题解:

单纯的模拟题,唯一的坑点就是当最后转换成的数为为0时输出长度为1。

代码:

/*I*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <iostream>
#include <cmath>
 
using namespace std;
 
char s[10],S[1000005];
 
int main(){
	
	int T,N;
	scanf("%d",&T);
	while(T--){
		scanf("%d %s",&N,s);
		scanf("%s",S);
		long long sum = 0;
		bool flag = false;
		for(int i=0 ; i<N ; ++i){
			int t = (int)(s[0]-S[i]);
			if(t < 0)t = -t;
			if(t < 10 && t!=0 && flag)++sum;
			if(t == 0 && flag)sum += 2;
			while(t){
				flag = true;
				t /= 10;
				++sum;
			}
		}
		if(sum == 0)++sum;
		printf("%lld\n",sum);
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/vocaloid01/article/details/82595209