PAT (Advanced Level) Practice 1120 Friend Numbers(20 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Puppettt/article/details/82180209

1120 Friend Numbers(20 分)

Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different frind ID's among them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 10​4​​.

Output Specification:

For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8
123 899 51 998 27 33 36 12

Sample Output:

4
3 6 9 26

题意:定义 一个数的每位数之和为 friend id ;问数组中有哪几个friend id

思路:处理每个数,set记录friend id,遍历输出

代码:

#include <bits/stdc++.h>
using namespace std;
int check(int x)
{
    int sum=0;
    while(x)
    {
        sum+=x%10;
        x/=10;
    }
    return sum;
}
set<int>s;
int main()
{
    int n;scanf("%d",&n);
    int x;
    for(int i=0;i<n;i++)
    {
        scanf("%d",&x);
        s.insert(check(x));
    }
    printf("%d\n",s.size());
    set<int>::iterator it;
    for(it=s.begin();it!=s.end();it++)
    {
        if(it!=s.begin())printf(" ");
        cout<<*it;
    }
    printf("\n");
}

猜你喜欢

转载自blog.csdn.net/Puppettt/article/details/82180209