1023 Have Fun with Numbers (20 分)PAT (Advanced Level) Practice

1023 Have Fun with Numbers (20 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

题目大意:给出一个长度不超过20的整数,问这个整数两倍后的数位是否为原数位的一个排列。不管是yes还是no最后都要输出整数乘以2的结果

比较愚蠢的写法,纯模拟

#include<iostream>
#include<string>
#include<algorithm>
#include<cstdio>
using namespace std;
int main()
{
	int a[10]={0},b[10]={0},jiewei,n,flag=0,sum;
	string c,d;
	cin>>c;
	n=c.length();
	
	//计算每个数字 出现次数 
	for(int i=0;i<n;i++)
	   a[c[i]-'0']++;
	
	jiewei=0;
	for(int i=n-1;i>=0;i--)
	{
		sum=(c[i]-'0')*2+jiewei;
		
		if(sum>=10)//要进位了
		{
		    d[i]=sum-10+'0';
			jiewei=1; 
		} 
		else
		{
			d[i]=sum+'0';
			jiewei=0;
		}	
	}
	
	if(jiewei==1)
	   b[1]++;
	//记录的d各个数字 出现次数
	for(int i=0;i<c.length();i++)
       b[d[i]-'0']++;
    
	for(int i=0;i<=9;i++)
	   if(a[i]!=b[i])
	   {//1-9当中有数字出现的次数不一样
			flag=1;
			break;
	   }	
	
	if(flag)
	   cout<<"No"<<endl;
	else
	   cout<<"Yes"<<endl;
	   
	if(jiewei==1)
	   cout<<"1";
	 for(int i=0;i<n;i++)
        printf("%d",d[i]);
    
     return 0;	
}

大神写法!

省内存,极大地压缩了内存!状压,大神不愧是大神。

#include <cstdio>
#include <string.h>
using namespace std;
int book[10];
int main() {
    char num[22];
    scanf("%s", num);
    int flag = 0, len = strlen(num);
    for(int i = len - 1; i >= 0; i--) {
        int temp = num[i] - '0';
        book[temp]++;
        temp = temp * 2 + flag;
        flag = 0;
        if(temp >= 10) {
            temp = temp - 10;
            flag = 1;
        }
        num[i] = (temp + '0');
        book[temp]--;
    }
    int flag1 = 0;
    for(int i = 0; i < 10; i++) {
        if(book[i] != 0)
            flag1 = 1;
    }
    printf("%s", (flag == 1 || flag1 == 1) ? "No\n" : "Yes\n");
    if(flag == 1) printf("1");
    printf("%s", num);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/mlm5678/article/details/82963599