PAT (Advanced Level) Practice 1035 Password (20)(20 分)

1035 Password (20)(20 分)

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

题解1:

读入字符串;

判断该字符串是否需要修改。如果需要修改,修改后写入数组,同时计数。

输出的时候,如果没有需要修改的地方,则account需要注意单复数。

源代码1:

#include <iostream>
using namespace std;
struct account {
	string team;
	string password;
};
int main()
{
	int n,count=0,i,j,flag;
	string t, p;
	struct account a[1000];
	cin >> n;
	for (i = 0; i < n; i++)
	{
		cin >> t >> p;
		flag = 0;
		for(j=0;j<p.length();j++)
		{ 
			if (p[j] == '1') {p[j] = '@'; flag = 1; continue;}
			else if (p[j] == '0'){p[j] = '%'; flag = 1; continue;}
			else if (p[j] == 'l'){p[j] = 'L'; flag = 1; continue;}
			else if (p[j] == 'O'){p[j] = 'o'; flag = 1; continue;}
		}
		if (flag)
		{
			a[count].team = t; a[count].password = p; count++;
		}
	}
	if (count)
	{
		cout << count << endl;
		for (i = 0; i < count; i++)
			cout << a[i].team << " " << a[i].password << endl;
	}
	else if(n==1)
			cout << "There is 1 account and no account is modified";
	else
		cout << "There are " << n << " accounts and no account is modified";
    return 0;
}

题解2:

把数组改成向量。每改一个密码,存入向量中,节省内存。将队名和密码合并成一个字符串,程序更加简练。

源代码2:

#include <iostream>
#include <vector>
using namespace std;

int main()
{
	int n,count=0,i,j,flag;
	string t, p;
	vector<string> a;
	cin >> n;
	for (i = 0; i < n; i++)
	{
		cin >> t >> p;
		flag = 0;
		for(j=0;j<p.length();j++)
		{ 
			if (p[j] == '1') {p[j] = '@'; flag = 1; continue;}
			else if (p[j] == '0'){p[j] = '%'; flag = 1; continue;}
			else if (p[j] == 'l'){p[j] = 'L'; flag = 1; continue;}
			else if (p[j] == 'O'){p[j] = 'o'; flag = 1; continue;}
		}
		if (flag)
		{
		  t=t+" "+p;
			a.push_back(t);
		}
	}
		count=a.size();
	if (count)
	{
		cout << count << endl;
		for (i = 0; i < count; i++)
			cout << a[i]<< endl;
	}
	else if(n==1)
			cout << "There is 1 account and no account is modified";
	else
		cout << "There are " << n << " accounts and no account is modified";

    return 0;
}



猜你喜欢

转载自blog.csdn.net/yi976263092/article/details/80730691