PAT (Advanced Level) Practice 1008 Elevator (20)(20 分)

1008 Elevator (20)(20 分)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

题解1:

电梯分上行和下行,从0层,0时间开始,每到新的一层,增加该段时间。再更新一下当前状态(当前处于第几层)。最后输出总时间。

源代码1:

#include <iostream>
using namespace std;
int main()
{
	int n, f1=0, f2=0;
	int i;
	int t=0;
	cin >> n;
	for (i = 0; i < n; i++)
	{
		cin >> f2;
		if (f1 < f2)
			t=t+(f2 - f1) * 6+5;
		else
			t = t + (f1 - f2) * 4 + 5;
		f1 = f2;
	}
	cout << t;
	return 0;
}




猜你喜欢

转载自blog.csdn.net/yi976263092/article/details/80737980
今日推荐