PAT (Advanced Level) Practice 1031 Hello World for U (20 分)

1031 Hello World for U (20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

AC代码:

/*1031 Hello World for U
给你一字符串,将它以'U型'输出 
其中n1=n3分别表示U型的左右两侧的字符数,n2等于底部的字符数, N表示字符串里字符的总数 
其中满足关系n1=n3=max{k|k<=n2, 3<=n2<=N}, n1+n2+n3-2=N 
*/
#include <iostream>
#include <string>
using namespace std;
int main(){
	string s;
	cin >> s;
	int N = s.length();
	int n1 = (N + 2) / 3;
	int n2 =  N + 2 - 2*n1;
	//将U型横着输出 
	for(int i = 0; i < n1-1; i++) {
		cout << s[i];
		//输出U中间空的字符串 
		for(int j = 0; j < n2-2; j++){
			cout << " ";
		}
		cout << s[N-i-1] << endl;
	}
	//输出最底部的那一行字符串 
	for(int k = 0; k < n2; k++) {
		cout << s[n1-1+k];
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/wangjian530/article/details/83048991