模拟_1046 Shortest Distance (20 分)

1046 Shortest Distance (20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <cmath>
#include <set>
#define INF 0x3f3f3f3f

using namespace std;
const int mod = 1e9+7;
const int maxn = 1e5+100;
typedef long long ll;
int a[maxn];

int main()
{
    int len = 0;
    int n,m,l,r;
    scanf("%d",&n);
    for(int i = 1;i <= n;i ++)
        scanf("%d",a+i),len += a[i];
    for(int i = 2;i <= n;i ++)
        a[i] += a[i-1];
    scanf("%d",&m);
    for(int i = 0;i < m;i ++)
    {
        scanf("%d%d",&l,&r);
        if(l > r) swap(l,r);
        printf("%d\n",min(a[r-1] - a[l-1],len - a[r-1] + a[l-1]));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/li1615882553/article/details/84574278