HDU1102 Constructing Roads(prim)

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

题意描述:
给出一个n*n的矩阵然后在给出一个m行已经连通的路口,现在需要求出路口全部连通的最短距离。

解题思路:
因为dis数组在最后是表示的是已经全部连通后,各个点到其它点的最短距离,那么就只需要在最初把已经连通的点的距离赋值为0,最后再把dis数组累加就是所要的那个最短距离。

#include<stdio.h>
#include<string.h>

int main(void)
{
	int e[110][110],book[110],dis[110];
	int i,j,n,q,a,b,min,inf=99999999;
	
	while(~scanf("%d",&n)){
		memset(book,0,sizeof(book));
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				scanf("%d",&e[i][j]);
				
		scanf("%d",&q);
		for(i=1;i<=q;i++){
			scanf("%d%d",&a,&b);
			e[a][b]=e[b][a]=0;
		}
		
		for(i=1;i<=n;i++)
			dis[i]=e[1][i];
		book[1]=1;
		
			int sum=0;
		int count=1;
		while(count<n){
			min=inf;
			for(i=1;i<=n;i++){
				if(book[i]==0&&dis[i]<min){
					j=i;
					min=dis[i];
				}
			}
			book[j]=1;
			count++;
			for(int k=1;k<=n;k++){
				if(book[k]==0&&dis[k]>e[j][k])
					dis[k]=e[j][k];
			 } 
		} 
		
		for(i=1;i<=n;i++)
			sum+=dis[i];
		printf("%d\n",sum);
	}
	return 0;
}
发布了53 篇原创文章 · 获赞 1 · 访问量 1350

猜你喜欢

转载自blog.csdn.net/fgets__/article/details/99591206