51nod 1091 (线段线段)

X轴上有N条线段,每条线段包括1个起点和终点。线段的重叠是这样来算的,10~20和12~25的重叠部分为12~20。

给出N条线段的起点和终点,从中选出2条线段,这两条线段的重叠部分是最长的。输出这个最长的距离。如果没有重叠,输出0。

Input

第1行:线段的数量N(2 <= N <= 50000)。 
第2 - N + 1行:每行2个数,线段的起点和终点。(0 <= s , e <= 10^9)

Output

输出最长重复区间的长度。

Sample Input

5
1 5
2 4
2 8
3 7
7 9

Sample Output

4
#include<cstdio>
#include<algorithm>
using namespace std;
struct sec{
	int l;
	int r;
}a[55000]; 
bool cmp(sec a,sec b){
	if(a.l==b.l) return a.r>b.r;
	return a.l<b.l;
}
int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		for(int i=0;i<n;i++){
			scanf("%d%d",&a[i].l,&a[i].r);
		}
		sort(a,a+n,cmp);
		sec temp;
		temp=a[0];
		int ans=0;
		for(int i=1;i<n;i++){
		    if(a[i].r<=temp.r){
		    	ans=max(ans,min(temp.r,a[i].r)-a[i].l);
			}
			else if(a[i].r>temp.r&&a[i].l<=temp.r){
				ans=max(ans,min(temp.r,a[i].r)-a[i].l);
				temp=a[i];
			}
		}
		
		printf("%d\n",ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40922859/article/details/81638215
今日推荐