poj-1328-Radar Installation

Radar Installation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 104992   Accepted: 23304

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source

题目大意:在一个二维直角坐标系中,给出n个海岛的坐标,现在在海岸线上装雷达,给出雷达的覆盖半径,问如何布置雷达,才能使雷达的数量最少,并求出最少的雷达数量

思路:典型的贪心,我们可以在输入时对其判断,若输入的坐标y最大的就大于半径,那不管如何布置,都将不能覆盖,现在我们不妨设每个海盗就是这个圆的圆心,求其与海岸线的交点,这个交点就是这个圆能覆盖的最远距离,然后将海岛变成区间,然后用区间覆盖解法去做就可以了

代码:

#include<map>
#include<stack>
#include<cmath>
#include<string>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 1100
#define ll long long
struct qq
{
    double l,r;
} a[maxn];
int cmp(qq A,qq B)
{
    return A.r<B.r;
}
int main()
{
    int d,n,q=1;
    while(scanf("%d%d",&n,&d)!=EOF)
    {
        if(d==0&&n==0)
            break;
        int i,j,k,x,y,ans=0,flag=0;
        double dis;
        for(i=0; i<n; i++)
        {
            scanf("%d%d",&x,&y);
            dis=sqrt((double)(d*d)-(double)(y*y));
            a[i].l=(double)x-dis;
            a[i].r=(double)x+dis;
            if(y>d)
                flag=1;
        }
        sort(a,a+n,cmp);
        printf("Case %d: ",q++);
        if(flag)
        {
            printf("-1\n");
            continue;
        }
        double temp=-99999999;
        for(i=0; i<n; i++)
        {
            if(a[i].l>temp)
            {
                ans++;
                temp=a[i].r;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lee371042/article/details/81044137