Fence Repair poj 3253

Fence Repair

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 64591   Accepted: 21253

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

大意:

给定一个num,

然后会给出 num行,

对应的表示每块木头的长度,表示把这num个数字的和作为原始的木头长度,每锯一次,就要消耗掉对应的木头长度的钱,最后木头的长度已经在上面给出,所以求出最少消耗的钱

解题思路:

根据小顶堆,每次取出两个最小的木块,拼接一个木块,相当于把上面的过程逆着来,然后知道队里面还剩最后一个木头,那就是原先的大木头,跳出循环,返回解。

注意:

这里需要注意  sum  要 long long 类型

printf  要  %lld

#include<stdio.h>
#include<iostream>
#include<queue>
#include<vector>
using namespace std;
int main(){

//    const int MAXN = 20001;

    int num;
    priority_queue<int,vector<int>,greater<int> > que;

    scanf("%d",&num);
    for(int i=0;i<num;i++){
        int temp;
        scanf("%d",&temp);
        que.push(temp);
    }

    long long count=0;
    while(que.size()>1){
        int temp = que.top();
        que.pop();
        int temp2 = que.top();
        que.pop();
        int sum = temp+temp2;
        count+=sum;
        que.push(sum);
    }


    printf("%lld\n",count);

    return 0;
}

pasture

  • n. 草地;牧场;牧草
  • vt. 放牧;吃草
  • n. (Pasture)人名;(英)帕斯彻;(法)帕斯蒂尔

 fence

  • n. 栅栏;围墙;剑术
  • vt. 防护;用篱笆围住;练习剑术
  • vi. 击剑;搪塞;围以栅栏;跳过栅栏

 planks

木板

purchases

购买

saw

  • vt. 看见;明白,了解;锯;锯成;锯开
  • vi. 锯;用锯;将某物锯成小块

kerf

切口

sawdust

木屑

capitalist

  • n. 资本家;资本主义者
  • adj. 资本主义的;资本家的

 intermediate

中间的,中级的

猜你喜欢

转载自blog.csdn.net/Willen_/article/details/84864724