PAT 乙级 1028 人口普查(排序)

1028 人口普查(20)(20 分)

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过200岁的老人,而今天是2014年9月6日,所以超过200岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数N,取值在(0, 10^5^];随后N行,每行给出1个人的姓名(由不超过5个英文字母组成的字符串)、以及按“yyyy/mm/dd”(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:

5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20

输出样例:

3 Tom John

 C++:

#include <stdio.h>
#include <vector>
#include <algorithm>
#include <string.h>
using namespace std;
struct inf {
	char a[6];
	int year;
	int month;
	int day;
};
bool cmp(struct inf a, struct inf b)
{
	if (a.year < b.year || (a.year == b.year&&a.month < b.month) || (a.year == b.year&&a.month == b.month&&a.day < b.day))
		return true;
	else
		return false;
}
int main()
{
	int n;
	int j = 0;
	scanf("%d", &n);
	struct inf b;
	vector<struct inf>v;
	for (int i=0;i < n;i++) {
		scanf("%s", &b.a);
		scanf("%d/%d/%d", &b.year, &b.month, &b.day);
		if (b.year > 1814 || (b.year == 1814 && b.month > 9) || (b.year == 1814 && b.month == 9 && b.day >= 6))
			if(b.year<2014||(b.year==2014&&b.month<9)||( b.year == 2014 && b.month==9&&b.day<=6))
				v.push_back(b);
	}
	sort(v.begin(),v.end(),cmp);
	if (v.size() >= 2)
		printf("%d %s %s", v.size(), v[0].a, v[v.size() - 1].a);
	else if (v.size() == 1)
		printf("%d %s %s", v.size(), v[0].a, v[0].a);
	else
		printf("0");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/zpjlkjxy/article/details/81777960
今日推荐