PAT乙级1028人口普查 20(分)

题目

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的――假设已知镇上没有超过 200 岁的老人,而今天是 2014 年 9 月 6 日,所以超过 200 岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数 N N N ,取值在 ( 0 , 1 0 5 ] (0, 10^5] ( 0 , 1 0 ? 5 ? ? ] ;随后 N N N 行,每行给出 1 个人的姓名(由不超过 5 个英文字母组成的字符串)、以及按 yyyy/mm/dd (即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:

5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20

输出样例:

3 Tom John

代码


#include<iostream>
#include<algorithm>
using namespace std;
int compare(int* a, int* b)
{
    
    
	if (a[1] > b[1])
		return 1;
	else if (a[1] == b[1] && a[2] > b[2])
		return 1;
	else if (a[1] == b[1] && a[2] == b[2] && a[3] >= b[3])
		return 1;
	return 0;
}
int main()
{
    
    
	int num,i,n=0;
	cin >> num;
	string* names = new string[num],input;
	int** a = new int*[num],year,month,day;
	for (i = 0; i < num; i++)
		a[i] = new int[4];
	for(i=0;i<num;i++)
	{
    
    
		cin >> names[i] >> input;
		year = atoi((input.substr(0, 4)).c_str());
		month = atoi((input.substr(5, 2)).c_str());
		day= atoi((input.substr(8, 2)).c_str());
		if (((year<1814)||(year== 1814 &&month<9)|| (year == 1814 && month == 9&&day<6))|| ((year >2014) || (year == 2014 && month >9) || (year == 2014 && month == 9 && day > 6)))
		{
    
    
			n++;
			num--;
			i--;
		}
		else
		{
    
    
			a[i][0] = i;
			a[i][1] = year;
			a[i][2] = month;
			a[i][3] = day;
		}
	}
	sort(a,a+num,compare);
	if (num > 0)
		cout << num << " " << names[a[num - 1][0]] << " " << names[a[0][0]];
	else
		cout << 0;
	return 0;
}

题目详情链接

猜你喜欢

转载自blog.csdn.net/qq_41985293/article/details/114983427