pat 1028.人口普查

1028 人口普查 (20 分)

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过 200 岁的老人,而今天是 2014 年 9 月 6 日,所以超过 200 岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数 N,取值在(0,10​5​​];随后 N 行,每行给出 1 个人的姓名(由不超过 5 个英文字母组成的字符串)、以及按 yyyy/mm/dd(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:

5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20

输出样例:

3 Tom John
#include<cstdio>

struct person
{
	char name[10];
	int year,month,day;
};
person old,young,min,max,temp;//最年长人,最年轻人,最早时间,最晚时间,临时变量 

bool later(person a,person b)//如果a的出生年月比b的晚,返回teue,否则返回false 
{
	if(a.year!=b.year) return a.year>=b.year;
	else if(a.month!=b.month) return a.month>=b.month;
	else return a.day>=b.day;
}

bool early(person a,person b)//如果a的出生年月比b的早,返回teue,否则返回false 
{                                                                         
	if(a.year!=b.year) return a.year<=b.year;                //写两个判断函数是因为判断出生年月是否合法时需要,一次判断不行 
	else if(a.month!=b.month) return a.month<=b.month;
	else return a.day<=b.day;
}

void init()
{
	min.year=young.year=1814;
	min.month=young.month=9;
	min.day=young.day=6;
	max.year=old.year=2014;
	max.month=old.month=9;
	max.day=old.day=6;
}

int main()
{
	init();
	int n,cnt=0;
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		scanf("%s %d/%d/%d",&temp.name,&temp.year,&temp.month,&temp.day);
		if(later(temp,min)&&early(temp,max))//判断出生年月是否合法,因为这一步需要些两个判断函数 
		{
			cnt++;
			if(early(temp,old)) old=temp;//如果现在输入的比目前最年长人出生早,更新old 
			if(later(temp,young)) young=temp;
		}
	}
	if(cnt==0) printf("0");
	else printf("%d %s %s",cnt,old.name,young.name); 
	return 0; 
} 

猜你喜欢

转载自blog.csdn.net/qq_41706331/article/details/88953275
今日推荐