PAT B 1028 人口普查

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过200岁的老人,而今天是2014年9月6日,所以超过200岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数N,取值在(0,10^5^];随后N行,每行给出1个人的姓名(由不超过5个英文字母组成的字符串)、以及按“yyyy/mm/dd”(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:

5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20

输出样例:

3 Tom John


#include<cstdio>
#include<cstring>
int main() {
	int n;
	scanf("%d", &n);
	char name[10];
	int yy, mm, dd;
	int count = 0;
	long long youth = 18140906, old = 20140906;
	char maxage[10], minage[10];

	for (int i = 0; i < n; i++) {
		scanf("%s %d/%d/%d", name, &yy, &mm, &dd);    // /的强大
		long long birth = yy * 10000 + mm * 100 + dd;    //这种日期比较方法,学到了
		if (birth >= 18140906 && birth <=20140906) {
			count++;
			if (birth < old) strcpy(maxage, name), old = birth;    //找最大最小年龄,字符串复制名字
			if (birth > youth) strcpy(minage, name), youth = birth;
		}
	}
	if (count) printf("%d %s %s\n", count, maxage, minage);
	else printf("0\n");    //日期全部不合法
	return 0;
}

猜你喜欢

转载自blog.csdn.net/joah_ge/article/details/80542368
今日推荐