poj3784 Running Median(对顶堆)

Running Median

Description

For this problem, you will write a program that reads in a sequence of 32-bit signed integers. After each odd-indexed value is read, output the median (middle value) of the elements received so far.
Input

The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by an odd decimal integer M, (1 ≤ M ≤ 9999), giving the total number of signed integers to be processed. The remaining line(s) in the dataset consists of the values, 10 per line, separated by a single space. The last line in the dataset may contain less than 10 values.
Output

For each data set the first line of output contains the data set number, a single space and the number of medians output (which should be one-half the number of input values plus one). The output medians will be on the following lines, 10 per line separated by a single space. The last line may have less than 10 elements, but at least 1 element. There should be no blank lines in the output.
Sample Input

3
1 9
1 2 3 4 5 6 7 8 9
2 9
9 8 7 6 5 4 3 2 1
3 23
23 41 13 22 -3 24 -31 -11 -8 -7
3 5 103 211 -311 -45 -67 -73 -81 -99
-33 24 56
Sample Output

1 5
1 2 3 4 5
2 5
9 8 7 6 5
3 12
23 23 22 22 13 3 5 5 3 -3
-7 -3

题意:动态维护中位数。

分析:见这里

代码

#include <cstdio>
#include <queue>
using namespace std;
priority_queue<int> maxq;
priority_queue<int,vector<int>,greater<int> >minq;
int n,m,a[100005];

void swap(int x,int y)
{
    x^=y;
    y^=x;
    x^=y;
}

int main()
{
//  freopen("1.in","r",stdin);
    int T;
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d%d",&m,&n);
        printf("%d %d\n",m,(n+1)/2);
        int x;
        scanf("%d",&x);
        a[1]=x;
        while (!minq.empty()) minq.pop();
        while (!maxq.empty()) maxq.pop();
        minq.push(x);
        int cnt=1;
        for (int i=3;i<=n;i+=2)
        {
            int y;
            scanf("%d%d",&x,&y);
            if (x<y) swap(x,y); 
            minq.push(x);
            maxq.push(y);
            int u=minq.top();
            int v=maxq.top();
            if (u<v)
            {
                minq.pop();
                maxq.pop();
                minq.push(v);
                maxq.push(u);
            }
            a[++cnt]=minq.top();
        }
        for (int i=1;i<=cnt;i++)
            if (i%10==0||i==cnt) printf("%d\n",a[i]);
                else printf("%d ",a[i]);
    }
}

猜你喜欢

转载自blog.csdn.net/zhanghaoxian1/article/details/81635968
今日推荐