SDUT OJ 数据结构实验之链表五:单链表的拆分

数据结构实验之链表五:单链表的拆分

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。

Input

第一行输入整数N;;
第二行依次输入N个整数。

Output

第一行分别输出偶数链表与奇数链表的元素个数; 
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。

Sample Input

10
1 3 22 8 15 999 9 44 6 1001

Sample Output

4 6
22 8 44 6 
1 3 15 999 9 1001

Hint

不得使用数组!

Source

#include <iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
typedef struct st
{
    struct st *next;
    int data;
} tree;
tree *h1,*h2;
int sum1,sum2;
void pre(tree *h)
{
    tree *t1,*t2,*p;
    h1=new tree;
    h2=new tree;
    h1->next=NULL;
    h2->next=NULL;
    t1=h1;
    t2=h2;
    p=h->next;
    while(p)
    {
        if(p->data%2==0)
        {
            t1->next=p;
            t1=p;
            sum1++;
        }
        else
        {
            t2->next=p;
            t2=p;
            sum2++;
        }
        p=p->next;
    }
t1->next=NULL;
             t2->next=NULL;
}
void out(tree *h)
{
    tree *p;
    p=h->next;
    while(p)
    {
        if(p->next==NULL)printf("%d\n",p->data);
        else printf("%d ",p->data);
        p=p->next;
    }
}
int main()
{
    tree *head,*tail,*p;
    int n;
    cin>>n;
    head=new tree;
    head->next=NULL;
    tail=head;
    for(int i=0; i<n; i++)
    {
        p=new tree;
        cin>>p->data;
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    sum1=0;
    sum2=0;
    pre(head);
    printf("%d %d\n",sum1,sum2);
    out(h1);
    out(h2);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41374539/article/details/81771645