Prime Ring Problem(Dfs求素数环)

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 

Input

n (0 < n < 20). 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
int n,cnt=1;
int vis[21];int A[21];
int prime[38]= {0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1};
void dfs(int cur)
{
    if(cur==n&&prime[A[0]+A[n-1]])
    {
        cout<<A[0];
        for(int i=1;i<n;i++)
        cout<<" "<<A[i];
        cout<<endl;
    }
    else for(int i=2;i<=n;i++)
        if(!vis[i]&&prime[i+A[cur-1]])
        {
            A[cur] = i;
            vis[i]=1;
            dfs(cur+1);
            vis[i]=0;
        }
}
int main(){
    A[0]=1;
    while(cin>>n)
    {
        memset(vis,0,sizeof(vis));
        cout<<"Case "<<cnt++<<":"<<endl;
        dfs(1);
      //  cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41988545/article/details/81664874