Prime Ring Problem_dfs

题目

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 

 

Input

n (0 < n < 20). 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

 题目大意

输入n 然后要形成一个环,使得相邻的两个数和为素数 

 这些数必须是不重复的 从1到n的n个数4

要求按字典序输出所有的可能素数环序列

算法:DFS 

代码 

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int n,m,a[21];
char b[21];
int su(int x)
{  
	int i;
	if(x<2) return 0;
	for(i=2;i*i<=x;i++) if(x%i==0)break;
	if(i*i<=x) return 0;
	else return 1;
}
void dfs(int x)
{
	if(x==n && su(a[n-1]+1))//如果搜到最后一位 并且结果正确
	{ 
        cout<<"1";
        for(int j=1;j<n;j++)
        cout<<" "<<a[j];
        cout<<endl;
        return;
    }
	for(int j=2;j<=n;j++) //找数字 
	{
		if(b[j]==0 && su(a[x-1]+j))	//没被标记并且和环中前一个数之和为素数
		{  
			a[x]=j; 		  //放入环中 
			b[j]=1; 		 //标记 
			dfs(x+1);	    //继续深搜 
			b[j]=0;        //如果失败标记为零 
		}
	}
	return;	
}

int main()
{
	int i,s=1;
	while(cin>>n)
	{
		memset(b,0,sizeof(b)); 
		a[0]=1;//将1放入环中 
		b[1]=1;//标记1 
		cout<<"Case "<<s<<":"<<endl;
		dfs(1); 
		cout<<endl;
		s++;
	} 
	return 0;
}

 终止条件是安排完了所有数并且满足素数环的条件,然后输出

如果还没安排完,就从1-n中找数字(不能被标记-也就是每个数字只能使用一次),并且和素数环中前一个数字和为素数,name放上环中。

猜你喜欢

转载自blog.csdn.net/baidu_41907100/article/details/87078133