HDU-1016 Prime Ring Problem(素数环)

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 66131    Accepted Submission(s): 28321


 

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

Input

n (0 < n < 20).

 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 

Sample Input

 

6 8

 

Sample Output

 

Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2

 

Source

Asia 1996, Shanghai (Mainland China)

 

Recommend

JGShining

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int n;
int a[40],book[40];
int is_prime[41]={0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0,1,0};
void dfs(int step)
{    
    int i;
	if(step==n+1&&is_prime[a[1]+a[n]])
	{    
	    for(i=1;i<n;i++)
		printf("%d ",a[i]);
		printf("%d\n",a[i]);
		return;
	}
	else
	{   
		for(i=2;i<=n;i++)
		{  
		   if(book[i]==0&&is_prime[i+a[step-1]])  //数组下标就表示某个数
			{
			  a[step]=i;
			  book[i]=1;
			  dfs(step+1);
			  book[i]=0;
	     	}
		}
	}
}
int main()
{   
     int cnt=1;
     a[0]=0,a[1]=1;
	while(scanf("%d",&n)!=EOF)
	{
		memset(book,0,sizeof(book));   //book[i]表示哪个数已经被用了 
		book[1]=1;
		printf("Case %d:\n",cnt++);
		dfs(2);
		printf("\n");
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/xigongdali/article/details/81591683