HDU 1016 Prime Ring Problem(素数环问题)

传送门:

http://acm.hdu.edu.cn/showproblem.php?pid=1016

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 63806    Accepted Submission(s): 27457


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 
Input
n (0 < n < 20).
 
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 
Sample Input
6 8
 
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
 
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
 
Source
 
Recommend
JGShining   |   We have carefully selected several similar problems for you:   1312  1072  1242  1175  1253 
 
分析:
经典的素数环问题
dfs
就是全排列的基础上加上素数环要求的检测
code:
#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
#define max_v 105
int a[max_v];
int vis[max_v];
int n;
int isp(int x)//素数检测
{
    for(int i=2;i<=sqrt(x);i++)
    {
        if(x%i==0)
            return 0;
    }
    return 1;
}
void dfs(int cur)//素数环问题 全排列思想加素数的检测
{
    if(cur==n&&isp(a[0]+a[n-1]))//判断到最后一个数了
    {
        printf("%d",a[0]);//打印
        for(int i=1;i<n;i++)
        {
            printf(" %d",a[i]);
        }
        printf("\n");
        return ;
    }else
    {
        for(int i=2;i<=n;i++)//找适合放在cur位置的i
        {
            if(!vis[i]&&isp(i+a[cur-1]))//满足要求
            {
                a[cur]=i;//放入
                vis[i]=1;//标记
                dfs(cur+1);//搜索
                vis[i]=0;//回退
            }
        }
    }
}
int main()
{
    int t=1,k=0;
    while(~scanf("%d",&n))
    {
        //if(k)
            //printf("\n");
        memset(vis,0,sizeof(vis));//标记清空
        a[0]=1;//确定1的位置
        printf("Case %d:\n",t);
        dfs(1);//从1开始放数
        t++;
        k++;
        printf("\n");
    }
    return 0;
}
 

猜你喜欢

转载自www.cnblogs.com/yinbiao/p/9313350.html