POJ 2356 Find a multiple(抽屉原理||深搜(数据大时不可用))

Problem Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.< br>< br>If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5 1 2 3 4 1

Sample Output

2 2 3

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<stack>
#include<vector>
#include<queue>
#include<map>
#define nn 500
#define mm 100001
#define inff 0x3fffffff
using namespace std;
#pragma comment(linker, "/STACK:102400000,102400000")
int n;
long long sum;
int a[10011];
int v[10011];
int st,ed,oo;
int main()
{
   while(~scanf("%d",&n))
   {
       sum=0;
       oo=0;
       memset(v,0,sizeof(v));
       for(int i=1;i<=n;i++)
       {
           scanf("%d",&a[i]);
           if(oo)//目的是让所有数据输完,加break不行
            continue;
           sum+=a[i];
           if(sum%n==0)
           {
               st=1;
               ed=i;
               oo=1;
             continue;
           }//第一种情况。就是不断加的和可以整除n,则从1-i输出a[i]就行
           if(!v[sum%n])
               v[sum%n]=i;//此时标记余数,即sum%n,看能不能出现两个相同的余数
           else
           {//若出现两个相同余数
               st=v[sum%n]+1;就是从开始的那个数+1到现在的i输出之间的值即可
               ed=i;
               oo=1;
           }
       }
       printf("%d\n",ed-st+1);//输出个数
       for(int i=st;i<=ed;i++)
        printf("%d\n",a[i]);
   }
}

代码思想类同与https://blog.csdn.net/lanshan1111/article/details/81626712 

猜你喜欢

转载自blog.csdn.net/lanshan1111/article/details/81664052