[POJ2356] Find a multiple 鸽巢原理

Find a multiple
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8776   Accepted: 3791   Special Judge

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3

Source

 
 

 
题解:
 
我们可以求出每个数的前缀和,如果有一项mod n等于0,那么直接输出它之前的所有数;
如果不存在,那么qzh[i]%n的值一定落在[1,n-1]之间,根据鸽巢原理,n个数落在n-1个地方,必定有一个地方重复,即qzh[i] % n = qzh[j] % n;
所以qzh[i]%n - qzh[j]%n = 0, 即i 到 j 之间的所有数加起来就是n的倍数;
所以直接暴力判断ok;
 

 
Code:
#include <iostream>
#include <cstdio>
#include  <map>
using namespace std;

int n;
int a[10010];
int qzh[10010];
map <int, int> mp;

int main()
{
    scanf("%d", &n);
    for (register int i = 1 ; i <= n ; i ++) scanf("%d", a + i);
    for (register int i = 1 ; i <= n ; i ++)
    {
        qzh[i] = qzh[i-1] + a[i];
        if (qzh[i] % n == 0) 
        {
            cout << i << endl;
            for (register int j = 1 ; j <= i ; j ++) printf("%d\n", a[j]);
            return 0;
        }
        if (mp[qzh[i]%n]!= 0) 
        {
            cout << i - mp[qzh[i]%n] << endl;
            for (register int j = mp[qzh[i]%n] + 1 ; j <= i ; j ++)
                printf("%d\n", a[j]);
            break;
        }
        mp[qzh[i]%n] = i;
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/zZh-Brim/p/9251714.html
今日推荐