POJ2356 Find a multiple【前缀和+抽屉原理】

Find a multiple
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10329 Accepted: 4402 Special Judge

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

扫描二维码关注公众号,回复: 10941091 查看本文章

2
2
3

Source
Ural Collegiate Programming Contest 1999

问题链接POJ2356 Find a multiple
问题简述:给定n个整数,从中选出若干个数,使得其和是n的倍数,输出选择的数的个数以及所选的各个数。
问题分析
    先算出n个数的前缀和放在数组sum[]中,如果其中(sum[i])有n的倍数则输出即可。
    否则,sum[1]%n,sum[2]%n,……,sum[n]%n这n个数必定在区间[1,n-1]之间。这相当于n个物品要放入n-1个抽屉中,根据抽屉原理,必定存在i,j满足i<j,使得sum[i]%n=sum[j]%n,那么(sum[j]-sum[i])%n=0。这时输出答案j-i,以及a[i+1],a[i+2]……a[j]即可。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ2356 Find a multiple */

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int N = 10000 + 1;
int a[N], sum[N], pos[N];

int main()
{
    int n;
    while(~scanf("%d", &n)) {
        for(int i = 1; i <= n; i++)
            scanf("%d", &a[i]);

        memset(pos, 0, sizeof(pos));
        sum[0] = 0;
        for(int i = 1; i <= n; i++) {
            sum[i] = sum[i - 1] + a[i];     // 前缀和

            if(sum[i] % n == 0) {
                printf("%d\n", i);
                for(int j = 1; j <= i; j++)
                    printf("%d\n", a[j]);
                break;
            }
            if(pos[sum[i] % n]) {
                printf("%d\n", i - pos[sum[i] % n]);
                for(int j = pos[sum[i] % n] + 1; j <= i; j++)
                    printf("%d\n", a[j]);
                break;
            }
            pos[sum[i] % n] = i;
        }
    }

    return 0;
}
发布了2289 篇原创文章 · 获赞 2373 · 访问量 265万+

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/105479723