hdu-3746-Cyclic Nacklace(KMP种next数组的应用,找循环节)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3746

Problem Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:


Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.  

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).

 

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

 

Sample Input

 

3 aaa abca abcde

 

Sample Output

 

0 2 5

题目大意:给t个字符串,对于每个字符串,增加一些字符使该字符串完成两次循环以上的整循环串

求最少增加的字符数量

KMP专题中,很容易就想到next数组,用next数组求出循环节,然后最后看  超出循环节的有多少个,输出补齐的数

如果正好是整数的循环节,输出0;

对了!!这个题的坑点!!!不能用memset!!!不知道为什么。。反正同样的代码,去掉就对 了。。。

ac:

#include<stdio.h>
#include<string.h>  
#include<math.h>  
  
//#include<map>   
//#include<set>
#include<deque>  
#include<queue>  
#include<stack>  
#include<bitset> 
#include<string>  
#include<iostream>  
#include<algorithm>  
using namespace std;  

#define ll long long  
#define INF 0x3f3f3f3f  
#define mod 998244353
//#define max(a,b) (a)>(b)?(a):(b)
//#define min(a,b) (a)<(b)?(a):(b) 
#define clean(a,b) memset(a,b,sizeof(a))// 水印 
//std::ios::sync_with_stdio(false);

void get_Next(char *p,int Next[])
{
	int plen=strlen(p);
	//cout<<plen<<endl;
	int j=0,k=-1;
	Next[0]=-1;
	while(j<plen)
	{
		//cout<<j<<" "<<k<<endl;
		if(k==-1||p[j]==p[k])
		{
			++j;
			++k;
			Next[j]=k;
		}
		else
			k=Next[k];
	}
}

int main()
{
	std::ios::sync_with_stdio(false);
	
	int t;
	cin>>t;
	while(t--)
	{
		char p[100100];
		int Next[100100];
		cin>>p;
		get_Next(p,Next);
		int plen=strlen(p);
//		cout<<plen<<endl;
//		for(int i=0;i<=plen;++i)
//			cout<<Next[i]<<" ";
//		cout<<endl;
		int l=plen-Next[plen];//循环节 
		if(l!=plen&&plen%l==0)//循环节被整除 
			cout<<0<<endl;
		else//有剩余的字符 
			cout<<l-Next[plen]%l<<endl;
	}
}

猜你喜欢

转载自blog.csdn.net/qq_40482358/article/details/81631290
今日推荐