HDU 3746 Cyclic Nacklace(求补齐循环节最小长度 KMP中next数组的使用 好题!!!)

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14416    Accepted Submission(s): 6016


Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
 
Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 
Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 
Sample Input
3 aaa abca abcde
 
Sample Output
0 2 5
 
Author
possessor WC
 
Source
 
Recommend
lcy   |   We have carefully selected several similar problems for you:   3336  1358  2222  3068  2896 
 
分析:
先要知道循环节的长度,首先排除没有循环节的情况,没有循环节的话,补全长度肯定是L
L-next[L-1]=循环节长度
L%循环节长度==0 不用补齐了
L%循环节不等于0 补齐长度=循环节长度-L%循环节长度
 
 
code:
#include<cstdio>
#include<iostream>
#include<cstring>
#include<memory>
using namespace std;
char wenben[1000005];
int next1[1000005];
void getnext1(char a[],int l,int next1[])
{
    //a字符串数组为子串,l为字符串a的长度,next为a的匹配值数组
    int j;
    int k=0;
    next1[0]=0;//初始化
    j=1;
    while(j<=l-1)
    {
        if(k==0)//a[0]和a[x]比较
        {
        if(a[k]==a[j])
        {

            k++;//k向后移动一位
            next1[j]=k;
            j++;
        }else
        {
            //k不动
            next1[j]=k;
            j++;
        }
        }
        if(k!=0)//k此时不在a[0]的位置上
        {
         if(a[k]==a[j])
         {
             k++;//k后移一位
             next1[j]=k;
             j++;//j后移一位
         }
         else
         {
             k=0;//k重新回到a[0]
         }
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",wenben);
        int L=strlen(wenben);
        getnext1(wenben,L,next1);
        if(next1[L-1]==0)//该字符没有现在没有循环节
        {
            printf("%d\n",L);
            continue;
        }
        int k=L-next1[L-1];//循环节的长度
        if(L%k==0)//不用补齐
            printf("0\n");
        else
            printf("%d\n",k-L%k);//比如abcab 3-(5%3)=1!!!
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/yinbiao/p/9458435.html
今日推荐