Cyclic Nacklace HDU - 3746 (KMP)

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task. 

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2: 

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden. 
CC is satisfied with his ideas and ask you for help.
InputThe first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases. 
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).OutputFor each case, you are required to output the minimum count of pearls added to make a CharmBracelet.Sample Input
3
aaa
abca
abcde
Sample Output
0
2
5

找最少添加几个是可以重复的。

根据 KMP 中的预处理就可以得出来。

len-(f[len-1]+1) 就是循环的长度,

不然就要补上。



#include <bits/stdc++.h>
using  namespace std;
char s[100009];
int f[100009],len;
void init(){
    f[0] = -1;
    len = strlen(s);
    for (int i = 1; i < len; i++){
        int j = f[i-1];
        while(s[j+1] != s[i] && j != -1) j  = f[j];
        if (s[j+1] == s[i]) f[i] = j+1; else f[i] = -1;
    }
return;
}

int main() {
    int tt;
    scanf("%d",&tt);
    while(tt--){
        scanf("%s",s);
        init();
        int s,t;
        t = f[len-1]+1; //一个循环节。。
        if (len % (len - t) == 0 && t != 0) printf("0\n"); else //判断已经完全重复,且重复度大于二。
            printf("%d\n",(len-t)-len%(len-t)); // 否则,输出差几个可以重复。
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/kidsummer/article/details/80384646
今日推荐