Cyclic Nacklace HDU - 3746 (Next数组求循环节)

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task. 

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2: 


Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden. 
CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases. 
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5

题目问,要让这个字符串循环至少需要补上多少的字符

不难想到KMP的自匹配数组。对于一个长为n的有循环节字符串,其循环节的长度为n-next[n]。为了将不能循环的部分进行补全,所有n%(n-next[n])(即不能形成完全循环)的字符串补上n-next-n%(n-next[n])即可补全

代码:

#include<algorithm>
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<stack>
#include<cmath>
#include<queue>
#include<set>
#include<map>
#define endl '\n'
#define sc(x) scanf("%d",&x)

using namespace std;
int nxt[100005];
char s[100005]; 
int n,m;
void getnext()
{
	nxt[0]=0,nxt[1]=0;
	int j=0;
	for(int i=1;i<m;i++)
	{
		j=nxt[i];
		while(j&&s[i]!=s[j]) j=nxt[j];
		if(s[i]==s[j]) nxt[i+1]=j+1;
		else nxt[i+1]=0;
		//cout<<nxt[i+1]<<' '<<i+1<<endl;
	}
}
int main()
{
	while(cin>>n)
	{
		while(n--)
		{
			scanf("%s",s);
			m=strlen(s);
			memset(nxt,0,sizeof(nxt));
			getnext();
			int ans;
			if(nxt[m]==0) ans=m;
			else if(m%(m-nxt[m])==0)ans=0;
			else ans=m-nxt[m]-m%(m-nxt[m]);
			cout<<ans<<endl;
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/baiyifeifei/article/details/81665726