HDU - 3746 Cyclic Nacklace next数组求 循环节

题目链接:点击查看

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task. 

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2: 


Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden. 
CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases. 
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5

题意:给你一个字符串,要求将字符串的全部字符最少循环2次需要添加的字符数。

题解:len-nex[len] 即为循环节的长度  看总长度是否是他的倍数,不是的话输出填多少个字符即可

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
char a[110000];
int la;
int nex[110000];
void getnex()
{
	nex[1]=0;
	int i=1,j=0;
	while(i<=la)
	{
		if(j==0||a[i]==a[j])
			nex[++i]=++j;
		else
			j=nex[j];
	}
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%s",a+1);
		la=strlen(a+1);
		getnex();
		if(nex[la+1]==1) printf("%d\n",la);
		else if(la%(la+1-nex[la+1])==0) printf("0\n");
		else printf("%d\n",la-nex[la+1]+1-la%(la+1-nex[la+1]));
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/mmk27_word/article/details/86715631