1009 Product of Polynomials

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ … NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output

3 3 3.6 2 6.0 1 1.6

参考代码:

#include<iostream>
#include<vector>
#include<cstdio>
using namespace std;

int main()
{
    vector<int>v;
    vector<double>v1(1002), v2(2005);
    int n1, n2, exp, cnt = 0;
    double coef;

    cin >> n1;
    for (int i = 1; i <= n1; i++)
    {
        cin >> exp >> coef;
        v1[exp] = coef;
        v.push_back(exp);
    }

    cin >> n2;
    for (int i = 1; i <= n2; i++)
    {
        //指数,系数
        cin >> exp >> coef;
        for (auto val : v)
        {
            v2[exp + val] += v1[val]*coef;
        }
    }

    for (auto val : v2)
    {
        if (val != 0)
            cnt++;
    }
    cout << cnt;
    for (int j=v2.size()-1;j>=0;j--)
    {
        if (v2[j] != 0)
            printf(" %d %.1f", j, v2[j]);
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/ssf_cxdm/article/details/81432625
今日推荐