Build A Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (\le100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

这题看起来简单 写起来也很简单  但是有点小细节把我弄个半天  数组里面的递归  函数的形参 只要一个下标 int n就行了  前面弄了半天数组放到形参里面 完全乱套了

说简单是因为这题目的类型跟 前面做的题目好多类似的地方  模版代码差不多可以照搬  题目要求层序输出 用队列就行了

#include <stdio.h>
#include <string.h>
#include <queue>
#include <algorithm>
using namespace std;

struct treenode {
	int item;
	int left;
	int right;
}t1[105];
int createtree(struct treenode t[], int n) {
	if (n) {
		int i;
		for (i = 0; i < n; i++) 
			scanf("%d %d", &t[i].left, &t[i].right);
	}
	return 0;
}
int p = 0, c[105];
void funnum(int n) {// 数组里面的递归  然后把中序遍历的数 赋给数的item
	if (t1[n].left != -1 ) 
		funnum(t1[n].left);
	t1[n].item = c[p]; p++;
	if (t1[n].right != -1)
		funnum(t1[n].right);
}

int main()
{
	int flag = 0;
	int r1, i, n;
	scanf("%d", &n);
	r1 = createtree(t1, n);
	for (i = 0; i < n; i++)
		scanf("%d", &c[i]);
	sort(c, c + n);//把数弄成中序遍历后的形式
	funnum(r1);
	queue<int>qu;
	qu.push(r1);
	while (qu.size()) {
		int s = qu.front();
		qu.pop();
		if (t1[s].left != -1) qu.push(t1[s].left);
		if (t1[s].right != -1) qu.push(t1[s].right);
		if (!flag) flag = 1;
		else printf(" ");
		printf("%d", t1[s].item);
		
	}
	printf("\n");
	return 0;
}


猜你喜欢

转载自blog.csdn.net/xmzyjr123/article/details/51999900