PAT 1099 Build A Binary Search Tree (30)

1099 Build A Binary Search Tree (30)(30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.

The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

思路:

 一棵排序二叉树的中序遍历就是这一组数的递增序列。先将这一组数按照递增排序,然后用中序遍历去复原这棵树,最后用层次遍历输出结果。

代码:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <map>  
#include <set>
using namespace std;

struct node
{
	int v, l, r;
}tree[105];

int val[105], n, k = 0;

void inorder(int root)
{
	if (tree[root].l != -1)
		inorder(tree[root].l);
	tree[root].v = val[k++];
	if (tree[root].r != -1)
		inorder(tree[root].r);
}

void levelorder()
{
	queue<node> q;
	q.push(tree[0]);
	bool flag = false;
	while (!q.empty())
	{
		node t = q.front();
		q.pop();
		if (t.l != -1)
			q.push(tree[t.l]);
		if (t.r != -1)
			q.push(tree[t.r]);
		if (!flag)
		{
			cout << t.v;
			flag = true;
		}
		else
			cout << " " << t.v;
	}
}

int main()
{
	cin >> n;
	for (int i = 0; i<n; i++)
		cin >> tree[i].l >> tree[i].r;
	for (int i = 0; i<n; i++)
		cin >> val[i];
	sort(val, val + n);
	inorder(0);
	levelorder();
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ryo_218/article/details/81461917