1099 Build A Binary Search Tree (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

思路:

1.输入:
观察figure给出的图,结点是按照先序遍历的先后标号的,而输入也是按照先序遍历给出结点信息。所以用一个结构表示结点,将所有结点存入vector,其在vector中的下标即为结点的序号,因此只需要顺序读入输入信息即可构造此树。
2.处理:
将构造好的树中序遍历,得到的序列一定是非递减的(二叉搜索树)。因此先将键值排序,再对树进行中序遍历,依次将键值赋值。这样就可以将这颗二叉搜索树建造好。
3.输出:
利用队列层序输出。

源码:

#include<bits/stdc++.h>
#include<stdio.h>
#define Max 101
using namespace std;
typedef struct node{
    int key;
    int left;
    int right;
}Node;
vector<Node> Tree;
int k[Max];
int cnt=0;
void in_travel(int s)
{
    if(Tree[s].left!=-1)
        in_travel(Tree[s].left);
    Tree[s].key=k[cnt++];
    if(Tree[s].right!=-1)
        in_travel(Tree[s].right);
}
int main()
{
    int n;cin>>n;
    Tree.resize(n+1);
    for(int i=0;i<n;i++)
        scanf("%d %d",&Tree[i].left,&Tree[i].right);

    for(int i=0;i<n;i++)
        cin>>k[i];
    sort(k,k+n);

    in_travel(0);

    queue<int> que;
    que.push(0);
    int f=1;
    while(!que.empty())
    {
        int t=que.front();
        que.pop();
        if(f)
        {
            cout<<Tree[t].key;
            f=0;
        }
        else
            cout<<" "<<Tree[t].key;
        if(Tree[t].left!=-1)que.push(Tree[t].left);
        if(Tree[t].right!=-1)que.push(Tree[t].right);
    }
}

发布了97 篇原创文章 · 获赞 12 · 访问量 2403

猜你喜欢

转载自blog.csdn.net/weixin_43301333/article/details/104080004